<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<title>Netflix In March 2020: 104 New Titles - The TV Answer Man!</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Netflix In March 2020: 104 New Titles - The TV Answer Man!" />
<meta property="og:description" content="Netflix next month (March 2020) plans to add 104 new TV shows and movies to its streaming lineup, including 58 originals. The new titles will include season three of Ozark (pictured above), a Netflix original series about an accountant who must turn money launderer to save his family from the Mob. Jason Bateman and LauraContinue reading" />
<meta property="og:url" content="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/" />
<meta property="og:site_name" content="The TV Answer Man!" />
<meta property="article:tag" content="netflix" />
<meta property="article:section" content="netflix" />
<meta property="article:published_time" content="2020-02-19T17:47:50+00:00" />
<meta property="og:image" content="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&#038;ssl=1" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="300" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Netflix next month (March 2020) plans to add 104 new TV shows and movies to its streaming lineup, including 58 originals. The new titles will include season three of Ozark (pictured above), a Netflix original series about an accountant who must turn money launderer to save his family from the Mob. Jason Bateman and LauraContinue reading" />
<meta name="twitter:title" content="Netflix In March 2020: 104 New Titles - The TV Answer Man!" />
<meta name="twitter:site" content="@swanniontv" />
<meta name="twitter:image" content="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&#038;ssl=1" />
<meta name="twitter:creator" content="@swanniontv" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://tvanswerman.com/#/schema/person/8c8bd63ac92ef14dba6f8783c3a47855","name":"TV Answer Man","image":{"@type":"ImageObject","@id":"https://tvanswerman.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/58aee31aeee8556e98c931850ba4e51b?s=96&d=identicon&r=g","caption":"TV Answer Man"},"logo":{"@id":"https://tvanswerman.com/#personlogo"},"description":"The TV Answer Man is veteran journalist Phillip Swann who has covered the TV technology scene for more than two decades. He will report on the latest news and answer your questions regarding new devices and services that are changing the way you watch television.","sameAs":[]},{"@type":"WebSite","@id":"https://tvanswerman.com/#website","url":"https://tvanswerman.com/","name":"The TV Answer Man!","inLanguage":"en-US","description":"Making television easy again. By Phillip Swann","publisher":{"@id":"https://tvanswerman.com/#/schema/person/8c8bd63ac92ef14dba6f8783c3a47855"},"potentialAction":{"@type":"SearchAction","target":"https://tvanswerman.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&ssl=1","width":600,"height":300},{"@type":"WebPage","@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#webpage","url":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/","name":"Netflix In March 2020: 104 New Titles - The TV Answer Man!","isPartOf":{"@id":"https://tvanswerman.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#primaryimage"},"datePublished":"2020-02-19T17:47:50+00:00","dateModified":"2020-02-19T17:47:50+00:00"},{"@type":"Article","@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#article","isPartOf":{"@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#webpage"},"author":{"@id":"https://tvanswerman.com/#/schema/person/8c8bd63ac92ef14dba6f8783c3a47855"},"headline":"Netflix In March 2020: 104 New Titles","datePublished":"2020-02-19T17:47:50+00:00","dateModified":"2020-02-19T17:47:50+00:00","commentCount":"1","mainEntityOfPage":{"@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#webpage"},"publisher":{"@id":"https://tvanswerman.com/#/schema/person/8c8bd63ac92ef14dba6f8783c3a47855"},"image":{"@id":"https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#primaryimage"},"keywords":"netflix","articleSection":"netflix,Television","inLanguage":"en-US"}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The TV Answer Man! &raquo; Feed" href="https://tvanswerman.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The TV Answer Man! &raquo; Comments Feed" href="https://tvanswerman.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The TV Answer Man! &raquo; Netflix In March 2020: 104 New Titles Comments Feed" href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.1 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.1';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-2446612-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-2446612-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tvanswerman.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://tvanswerman.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1579711166' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='jetpack-layout-grid-css'  href='https://tvanswerman.com/wp-content/plugins/layout-grid/style.css?ver=1573154538' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-event-countdown-css'  href='https://tvanswerman.com/wp-content/plugins/full-site-editing/event-countdown-block/style.css?ver=1576877996' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-timeline-css'  href='https://tvanswerman.com/wp-content/plugins/full-site-editing/jetpack-timeline/style.css?ver=1576877996' type='text/css' media='all' />
<link rel='stylesheet' id='blog-posts-block-view-css'  href='https://tvanswerman.com/wp-content/plugins/full-site-editing/blog-posts-block/dist/view.css?ver=1.0.0-alpha.20' type='text/css' media='all' />
<link rel='stylesheet' id='posts-list-block-style-css'  href='https://tvanswerman.com/wp-content/plugins/full-site-editing/posts-list-block/dist/posts-list-block.css?ver=1576100336' type='text/css' media='all' />
<link rel='stylesheet' id='heart-and-style-style-css'  href='https://tvanswerman.com/wp-content/themes/heart-and-style/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='heart-and-style-plugins-css'  href='https://tvanswerman.com/wp-content/themes/heart-and-style/css/plugins.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://tvanswerman.com/wp-content/themes/heart-and-style/css/fonts/font-awesome/font-awesome.css?ver=5.3.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='heart-and-style-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C100%2C300%2C700%2C900%7CArbutus+Slab&#038;subset=latin%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-global-styles-frontend-style-css'  href='https://tvanswerman.com/wp-content/plugins/full-site-editing/global-styles/static/blank.css?ver=1909241817' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css' type='text/css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.2.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.2.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/tvanswerman.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tvanswerman.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.0.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://tvanswerman.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tvanswerman.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tvanswerman.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7hAvl-7W7' />
<link rel="alternate" type="application/json+oembed" href="https://tvanswerman.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftvanswerman.com%2F2020%2F02%2F19%2Fnetflix-in-march-2020-104-new-titles%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tvanswerman.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftvanswerman.com%2F2020%2F02%2F19%2Fnetflix-in-march-2020-104-new-titles%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.3.1" /><meta name="google-site-verification" content="JOmMPWXctDtf_DnnvaXc4rG_5kPWlfKER0gs7v5Qg04" />
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://tvanswerman.com/xmlrpc.php"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-7127282532927704",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<link rel="amphtml" href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/amp/"><link rel="icon" href="https://i1.wp.com/tvanswerman.com/wp-content/uploads/2016/12/swanni2.jpeg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/tvanswerman.com/wp-content/uploads/2016/12/swanni2.jpeg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/tvanswerman.com/wp-content/uploads/2016/12/swanni2.jpeg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/tvanswerman.com/wp-content/uploads/2016/12/swanni2.jpeg?fit=250%2C250&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-30511 single-format-standard">

	<div id="page" class="site">

		<header id="header">

			<div class="wrapper clearfix">

				<div id="logo">
																<p class="site-title"><a href="https://tvanswerman.com/" rel="home">The TV Answer Man!</a></p>
																					<p class="site-description">Making television easy again. By Phillip Swann</p>
									</div><!-- #logo -->

									<nav id="navigation">
						<div class="menu-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-29608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-29608"><a href="https://tvanswerman.com">Home</a></li>
<li id="menu-item-29610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29610"><a href="https://tvanswerman.com/4k-tv/">4K TV</a></li>
<li id="menu-item-29611" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29611"><a href="https://tvanswerman.com/streaming-secrets/">Streaming Secrets</a></li>
<li id="menu-item-29612" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29612"><a href="https://tvanswerman.com/shopping-tips/">Shopping Tips</a></li>
<li id="menu-item-29613" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29613"><a href="https://tvanswerman.com/better-picture-quality/">Picture Quality</a></li>
<li id="menu-item-29614" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29614"><a href="https://tvanswerman.com/contact/">Contact</a></li>
<li id="menu-item-29615" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29615"><a href="https://tvanswerman.com/better-picture-quality/">Picture Quality</a></li>
<li id="menu-item-29616" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29616"><a href="https://tvanswerman.com/contact/">Contact</a></li>
<li id="menu-item-29617" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29617"><a href="https://tvanswerman.com/about/">About</a></li>
</ul></div>					</nav><!-- #navigation -->
				
								<div id="header-social">

					
										<a href="#" class="header-search-hook-show"><span class="fa fa-search"></span><span class="screen-reader-text">Show search form</span></a>

					
					<span class="header-search-mobile-nav-hook"><span class="fa fa-reorder"></span>Menu<select><option>- Select Page -</option><option value="https://tvanswerman.com" >Home</option><option value="https://tvanswerman.com/4k-tv/" >4K TV</option><option value="https://tvanswerman.com/streaming-secrets/" >Streaming Secrets</option><option value="https://tvanswerman.com/shopping-tips/" >Shopping Tips</option><option value="https://tvanswerman.com/better-picture-quality/" >Picture Quality</option><option value="https://tvanswerman.com/contact/" >Contact</option><option value="https://tvanswerman.com/better-picture-quality/" >Picture Quality</option><option value="https://tvanswerman.com/contact/" >Contact</option><option value="https://tvanswerman.com/about/" >About</option></select></span>

					<div class="header-search">
						<form role="search" method="get" class="search-form" action="https://tvanswerman.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						<span class="header-search-hook-hide"><span class="fa fa-remove"></span><span class="screen-reader-text">Hide search form</span></span>
					</div><!-- .sas-search -->

				</div><!-- #header-social -->

			</div><!-- .wrapper -->

		</header><!-- #header -->

		
		
		<div id="main" class="site-content">

			<div class="wrapper clearfix">

	<div id="content"  role="main">

		
	<div class="blog-post-single-thumb">
		<img width="600" height="300" src="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&amp;ssl=1" class="attachment-heart-and-style-posts-listing size-heart-and-style-posts-listing wp-post-image" alt="" srcset="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 600px) 100vw, 600px" data-attachment-id="30523" data-permalink="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/ozark3/" data-orig-file="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&amp;ssl=1" data-orig-size="600,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ozark3" data-image-description="" data-medium-file="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=300%2C150&amp;ssl=1" data-large-file="https://i0.wp.com/tvanswerman.com/wp-content/uploads/2020/02/ozark3.jpg?fit=600%2C300&amp;ssl=1" />	</div><!-- .blog-post-single-thumb -->

<h1 class="blog-post-single-title entry-title">Netflix In March 2020: 104 New Titles</h1>


<div class="blog-post-single-meta clearfix">

	<div class="blog-post-single-meta-info">

		<span class="post-meta-author">
			<img alt='' src='https://secure.gravatar.com/avatar/58aee31aeee8556e98c931850ba4e51b?s=35&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/58aee31aeee8556e98c931850ba4e51b?s=70&#038;d=identicon&#038;r=g 2x' class='avatar avatar-35 photo' height='35' width='35' />			By <span class="author vcard blog-post-single-meta-info-author"><a class="url fn n" href="https://tvanswerman.com/author/swanniontv/">TV Answer Man</a></span>		</span><!-- .post-meta-author -->
		<span class="post-meta-cats">
			in <span class="blog-post-single-meta-info-cats"><a href="https://tvanswerman.com/category/netflix/" rel="category tag">netflix</a>, <a href="https://tvanswerman.com/category/television/" rel="category tag">Television</a></span>		</span><!-- .post-meta-cats -->
		<span class="post-meta-date">
			<span class="post-meta-date-on">on</span> <a href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/"><time class="entry-date published updated" datetime="2020-02-19T12:47:50-05:00">February 19, 2020</time></a>		</span><!-- .post-meta-date -->

	</div><!-- .blog-post-single-meta-info -->

	<div class="blog-post-single-meta-social">
		<div class="blog-post-share">
			<a href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#comments"><span class="fa fa-comments"></span><span class="blog-post-share-count">One comment</span></a>
		</div><!-- .blog-post-share -->
	</div><!-- .blog-post-single-meta-social -->

</div><!-- .blog-post-meta -->

<div class="blog-post-single-content">
	<p>Netflix next month (March 2020) plans to add 104 new TV shows and movies to its streaming lineup, including 58 originals.</p>
<!-- WP QUADS Content Ad Plugin v. 1.8.8 -->
<div class="quads-location quads-ad1" id="quads-ad1" style="float:none;margin:0px;">

 <!-- WP QUADS - Quick AdSense Reloaded v.1.8.8 Content AdSense async --> 

<script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">
var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="7629716983" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="7629716983" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="7629716983" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="7629716983" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script>

 <!-- end WP QUADS --> 


</div>

<p>The new titles will include season three of Ozark (pictured above), a Netflix original series about an accountant who must turn money launderer to save his family from the Mob. Jason Bateman and Laura Linney star in the tense drama whose first and second seasons captured <a href="https://www.rottentomatoes.com/tv/ozark"><strong>critical ratings</strong></a> of 70 and 76 respectively at RottenTomatoes.com.</p>
<p>Also notable in March: Spenser Confidential, a Netflix original film starring Mark Wahlberg as a former Boston police detective who returns home to investigate the mysterious death of two city policemen; season two of Dirty Money, a Netflix original documentary about corporate corruption; Lost Girls, a Netflix original mystery film starring Amy Ryan as a mother investigating her daughter&#8217;s disappearance; The Valhalla Murders, a Netflix original drama about a serial killer in Iceland; and season three of The Boss Baby: Back In Business, a Netflix original animated series based on the hit children&#8217;s movie.</p>
<p>There are also several classic movies coming next month including The Shawshank Redemption, Goodfellas, There Will Be Blood and Tootsie.</p>
<p>Here is the complete list of new titles coming next month to Netflix streaming:</p>
<p>March 1<br />
Go! Go! Cory Carson: Season 2 &#8212; NETFLIX FAMILY<br />
Always a Bridesmaid<br />
Beyond the Mat<br />
Cop Out<br />
Corpse Bride</p>
<p>Donnie Brasco<br />
Freedom Writers<br />
Ghosts of Girlfriends Past<br />
GoodFellas<br />
Haywire</p>
<p>He&#8217;s Just Not That Into You<br />
Hook<br />
Hugo<br />
Kung Fu Panda 2<br />
Lemony Snicket&#8217;s A Series of Unfortunate Events</p>
<p>Life as We Know It<br />
Looney Tunes: Back in Action<br />
Outbreak<br />
Resident Evil: Apocalypse<br />
Resident Evil: Extinction</p>
<p>Richie Rich<br />
Semi-Pro<br />
Sleepover<br />
Space Jam<br />
The Gift</p>
<p>The Interview<br />
The Shawshank Redemption<br />
The Story of God with Morgan Freeman: Season 3<br />
There Will Be Blood<br />
Tootsie</p>
<p>Valentine&#8217;s Day<br />
Velvet Colección: Grand Finale<br />
ZZ Top: That Little Ol’ Band from Texas</p>
<p>March 3<br />
Taylor Tomlinson: Quarter-Life Crisis (Netflix Comedy Special)</p>
<p>March 4<br />
Lil Peep: Everybody&#8217;s Everything</p>
<p>March 5<br />
Castlevania: Season 3 (Netflix Anime)<br />
Mighty Little Bheem: Festival of Colors (Netflix Family)</p>
<p><iframe style="border: none;" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&amp;p=12&amp;l=ur1&amp;category=amazonhomepage&amp;f=ifr&amp;linkID=b5d8d3c0ad6d7d56f617cd5384813241&amp;t=tvpredictions-20&amp;tracking_id=tvpredictions-20" width="300" height="250" frameborder="0" marginwidth="0" scrolling="no"></iframe></p>
<p>March 6<br />
Guilty (Netflix Film)<br />
I am Jonas (Netflix Film)<br />
Paradise PD: Part 2 (Netflix Original)<br />
The Protector: Season 3 (Netflix Original)<br />
Spenser Confidential (Netflix Film)</p>
<p>Twin Murders: The Silence of the White City (Netflix Film)<br />
Ugly Delicious: Season 2 (Netflix Documentary)</p>
<p>March 8<br />
Sitara: Let Girls Dream (Netflix Film)</p>
<p>March 10<br />
Carmen Sandiego: To Steal or Not to Steal — NETFLIX FAMILY<br />
Marc Maron: End Times Fun — NETFLIX COMEDY SPECIAL</p>
<p>March 11<br />
The Circle Brazil — NETFLIX ORIGINAL<br />
Dirty Money: Season 2 — NETFLIX DOCUMENTARY<br />
Last Ferry<br />
On My Block: Season 3 — NETFLIX ORIGINAL<br />
Summer Night</p>
<p>March 12<br />
Hospital Playlist (Netflix original)</p>
<p>March 13<br />
100 Humans — NETFLIX ORIGINAL<br />
BEASTARS — NETFLIX ANIME<br />
Bloodride — NETFLIX ORIGINAL<br />
Elite: Season 3 — NETFLIX ORIGINAL<br />
Go Karts — NETFLIX FILM</p>
<!-- WP QUADS Content Ad Plugin v. 1.8.8 -->
<div class="quads-location quads-ad2" id="quads-ad2" style="float:none;margin:0px;">

 <!-- WP QUADS - Quick AdSense Reloaded v.1.8.8 Content AdSense async --> 

<script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">
var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-7127282532927704" data-ad-slot="7148808101" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-7127282532927704" data-ad-slot="7148808101" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-7127282532927704" data-ad-slot="7148808101" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-7127282532927704" data-ad-slot="7148808101" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script>

 <!-- end WP QUADS --> 


</div>

<p>Kingdom: Season 2 — NETFLIX ORIGINAL<br />
Lost Girls — NETFLIX FILM<br />
The Valhalla Murders — NETFLIX ORIGINAL<br />
Women of the Night — NETFLIX ORIGINAL</p>
<p>March 15<br />
Aftermath</p>
<p>March 16<br />
The Boss Baby: Back in Business: Season 3 — NETFLIX FAMILY<br />
Search Party<br />
Silver Linings Playbook<br />
Tinker, Tailor, Soldier, Spy<br />
The Young Messiah</p>
<p><iframe style="border: none;" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&amp;p=12&amp;l=ur1&amp;category=amazonhomepage&amp;f=ifr&amp;linkID=b5d8d3c0ad6d7d56f617cd5384813241&amp;t=tvpredictions-20&amp;tracking_id=tvpredictions-20" width="300" height="250" frameborder="0" marginwidth="0" scrolling="no"></iframe></p>
<p>March 17<br />
Bert Kreischer: Hey Big Boy — NETFLIX COMEDY SPECIAL<br />
All American: Season 2<br />
Black Lightning: Season 3<br />
Shaun the Sheep: Adventures from Mossy Bottom — NETFLIX FAMILY</p>
<p>March 18<br />
Lu Over the Wall</p>
<p>March 19<br />
Altered Carbon: Resleeved — NETFLIX ANIME<br />
Feel Good — NETFLIX ORIGINAL</p>
<p>March 20<br />
A Life of Speed: The Juan Manuel Fangio Story — NETFLIX DOCUMENTARY<br />
Archibald’s Next Big Thing: Season 2 — NETFLIX FAMILY<br />
Buddi — NETFLIX FAMILY<br />
Dino Girl Gauko: Season 2 — NETFLIX FAMILY<br />
Greenhouse Academy: Season 4 — NETFLIX FAMILY</p>
<p>The Letter for the King — NETFLIX FAMILY<br />
Maska — NETFLIX FILM<br />
The Platform — NETFLIX FILM<br />
Self Made: Inspired by the Life of Madam C.J. Walker — NETFLIX ORIGINAL<br />
Ultras — NETFLIX FILM<br />
Tiger King — NETFLIX DOCUMENTARY</p>
<p>March 23<br />
Sol Levante — NETFLIX ANIME</p>
<p>March 25th<br />
Crip Camp: A Disability Revolution — NETFLIX DOCUMENTARY<br />
Curtiz — NETFLIX FILM<br />
The Occupant (Hogar) — NETFLIX FILM<br />
Signs — NETFLIX ORIGINAL<br />
YooHoo to the Rescue: Season 3 — NETFLIX FAMILY</p>
<p>March 26th<br />
7SEEDS: Part 2 — NETFLIX ANIME<br />
Blood Father<br />
Unorthodox — NETFLIX ORIGINAL</p>
<p>March 27th<br />
Car Masters: Rust to Riches: Season 2 — NETFLIX ORIGINAL<br />
The Decline — NETFLIX FILM<br />
Dragons: Rescue Riders: Hunt for the Golden Dragon — NETFLIX FAMILY<br />
Il processo — NETFLIX ORIGINAL<br />
Killing Them Softly</p>
<p>Ozark: Season 3 — NETFLIX ORIGINAL<br />
There’s Something in the Water<br />
True: Wuzzle Wegg Day — NETFLIX FAMILY<br />
Uncorked — NETFLIX FILM</p>
<p><iframe style="border: none;" src="//rcm-na.amazon-adsystem.com/e/cm?o=1&amp;p=12&amp;l=ur1&amp;category=amazonhomepage&amp;f=ifr&amp;linkID=b5d8d3c0ad6d7d56f617cd5384813241&amp;t=tvpredictions-20&amp;tracking_id=tvpredictions-20" width="300" height="250" frameborder="0" marginwidth="0" scrolling="no"></iframe></p>
<p><em>Need to buy something today? Please buy it using one of the Amazon links here. This site receives a small portion of each purchase, which helps us continue to provide these articles.</em></p>
<p><em>Have a question about new TV technologies? Send it to The TV Answer Man at swann@tvpredictions.com. Please include your first name and hometown in your message.</em></p>
<p>— Phillip Swann</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-30511" class="share-twitter sd-button share-icon" href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-30511" class="share-facebook sd-button share-icon" href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<!-- WP QUADS Content Ad Plugin v. 1.8.8 -->
<div class="quads-location quads-ad3" id="quads-ad3" style="float:none;margin:0px;">

 <!-- WP QUADS - Quick AdSense Reloaded v.1.8.8 Content AdSense async --> 

<script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">
var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="8806222867" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="8806222867" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="8806222867" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-7127282532927704" data-ad-slot="8806222867" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script>

 <!-- end WP QUADS --> 


</div>

<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-107626255-30511-5e4d8670db103' data-src='https://widgets.wp.com/likes/#blog_id=107626255&amp;post_id=30511&amp;origin=tvanswerman.com&amp;obj_id=107626255-30511-5e4d8670db103' data-name='like-post-frame-107626255-30511-5e4d8670db103'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div><!-- .blog-post-single-content -->

	<div class="blog-post-single-tags post-meta-tags">
		Tags: <a href="https://tvanswerman.com/tag/netflix/" rel="tag">netflix</a>	</div><!-- .blog-post-single-tags -->

<div class="blog-post-single-pagination">
	</div><!-- .blog-post-single-pagination -->

	<div class="entry-author">
		<div class="author-avatar">
			<img alt='' src='https://secure.gravatar.com/avatar/58aee31aeee8556e98c931850ba4e51b?s=85&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/58aee31aeee8556e98c931850ba4e51b?s=170&#038;d=identicon&#038;r=g 2x' class='avatar avatar-85 photo' height='85' width='85' />		</div><!-- .author-avatar -->

		<div class="author-heading">
			<h2 class="author-title">Published by <span class="author-name">TV Answer Man</span></h2>
		</div><!-- .author-heading -->

		<p class="author-bio">
			The TV Answer Man is veteran journalist Phillip Swann who has covered the TV technology scene for more than two decades. He will report on the latest news and answer your questions regarding new devices and services that are changing the way you watch television.			<a class="author-link" href="https://tvanswerman.com/author/swanniontv/" rel="author">
				View all posts by TV Answer Man			</a>
		</p><!-- .author-bio -->
	</div><!-- .entry-auhtor -->
	
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://tvanswerman.com/2020/02/19/hulu-in-march-2020-81-new-titles/" rel="prev"><span class="blog-post-single-nav-button"><span class="fa fa-angle-left"></span>Previous post</span>Hulu In March 2020: 81 New Titles</a></div></div>
	</nav>
<div id="comments" class="comments-area">

	
		<h2 class="comments-title">
			1 comments on &ldquo;Netflix In March 2020: 104 New Titles&rdquo;		</h2>

		
		<ol class="comment-list">
					<li id="comment-14246" class="comment even thread-even depth-1">
			<article id="div-comment-14246" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/f6d5d5655236f979386bde8f6b7e8978?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/f6d5d5655236f979386bde8f6b7e8978?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />						<b class="fn">Paul McCabe</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://tvanswerman.com/2020/02/19/netflix-in-march-2020-104-new-titles/#comment-14246">
							<time datetime="2020-02-19T13:36:21-05:00">
								February 19, 2020 at 1:36 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Why do you only cover   streaming programing. What about PBS, or  the 4 Big OTA Networks?. Is tv just about streaming.  According to AC Neilson tv ratings from October 2017 72 Percent of Netflix viewers were watching former network reruns, and only 28 Percent were viewing Netflix original programs.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-14246' data-commentid="14246" data-postid="30511" data-belowelement="div-comment-14246" data-respondelement="respond" aria-label='Reply to Paul McCabe'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/19/netflix-in-march-2020-104-new-titles/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=netflix-in-march-2020-104-new-titles#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=107626255&#038;postid=30511&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.2.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=a4139063127f681708341ad8f3a65d89e1ae1f6f#parent=https%3A%2F%2Ftvanswerman.com%2F2020%2F02%2F19%2Fnetflix-in-march-2020-104-new-titles%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dnetflix-in-march-2020-104-new-titles" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

	</div><!-- #content -->

	
			</div><!-- .wrapper -->

		</div><!-- #main -->

		
		<footer id="footer" class="site-footer">

			<div id="footer-top">

				<div class="wrapper clearfix">

					<div id="footer-social">
											</div><!-- #footer-social -->

					<div id="footer-scroll-to-top">
						<span class="scroll-to-top">To top<span class="fa fa-chevron-up"></span></span>
					</div><!-- #footer-scroll-to-top -->

				</div><!-- .wrapper -->

			</div><!-- #footer-top -->

			
			<div id="footer-bottom">

				<div class="wrapper clearfix">

					
					<div id="footer-copyright">						
						<a href="https://wordpress.com/?ref=footer_custom_powered">Powered by WordPress.com</a>.
						
											</div><!-- #footer-copyright -->

				</div><!-- .wrapper -->

			</div><!-- #footer-bottom -->

		</footer><!-- #footer -->

	</div><!-- #page -->

	<!--  -->
<!-- Your Google Analytics Plugin is missing the tracking ID -->
	<div style="display:none">
	<div class="grofile-hash-map-58aee31aeee8556e98c931850ba4e51b">
	</div>
	<div class="grofile-hash-map-58aee31aeee8556e98c931850ba4e51b">
	</div>
	<div class="grofile-hash-map-f6d5d5655236f979386bde8f6b7e8978">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/tvanswerman.com\/2020\/02\/19\/netflix-in-march-2020-104-new-titles\/":30511};
	</script>
				<link rel='stylesheet' id='wpcom-layout-grid-front-css'  href='https://tvanswerman.com/wp-content/plugins/layout-grid/blocks/front.css?ver=1573154538' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://tvanswerman.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://tvanswerman.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://tvanswerman.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://tvanswerman.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://tvanswerman.com/wp-content/plugins/full-site-editing/blog-posts-block/dist/view.js?ver=187983f2ec7aa568a46de75a4da480a2'></script>
<script type='text/javascript' src='https://tvanswerman.com/wp-content/plugins/full-site-editing/event-countdown-block/blocks/event-countdown.js?ver=1576877996'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://tvanswerman.com/wp-content/themes/heart-and-style/js/plugins.js?ver=1.0'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/effect.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MTAjax = {"ajaxurl":"https:\/\/tvanswerman.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tvanswerman.com/wp-content/themes/heart-and-style/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/_inc/build/jquery.jetpack-resize.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/_inc/build/likes/queuehandler.min.js'></script>
<script async="async" type='text/javascript' src='https://tvanswerman.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202008#ver=202008' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=107626255&postid=30511&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a4139063127f681708341ad8f3a65d89e1ae1f6f#parent=https%3A%2F%2Ftvanswerman.com%2F2020%2F02%2F19%2Fnetflix-in-march-2020-104-new-titles%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dnetflix-in-march-2020-104-new-titles" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=107626255&postid=30511&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=a4139063127f681708341ad8f3a65d89e1ae1f6f#parent=https%3A%2F%2Ftvanswerman.com%2F2020%2F02%2F19%2Fnetflix-in-march-2020-104-new-titles%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dnetflix-in-march-2020-104-new-titles";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.1',blog:'107626255',post:'30511',tz:'-5',srv:'tvanswerman.com'} ]);
	_stq.push([ 'clickTrackerInit', '107626255', '30511' ]);
</script>

</body>
</html>